Planned maintenance - February 12th 2025 @ 23:00

Incident Report for Apalo

Resolved

Update completed.
Posted Feb 13, 2025 - 09:14 UTC

Update

Release notes: APALO V1.5 2024-05


Release date 12t February 2025
Features & Improvements

User Experience

ACD group history: Smarter notifications for unanswered outbound calls
As an ACD agent utilizing the group call history feature, the primary objective is to reduce unnecessary notifications regarding unhandled ACD calls, thereby improving the user experience. The current challenge stems from unanswered outbound calls associated with the ACD group's CLI, which clutter the call history with irrelevant entries.
To address this issue, the proposed solution involves refining the notification logic and the open cases counter. This adjustment would ensure that unanswered outbound ACD calls neither trigger notifications nor contribute to the counter. By implementing this change, we can preserve the integrity of the ACD group's call history while preventing agents from receiving misleading notifications about unhandled calls.
Under this new framework, only answered inbound or outbound ACD calls would reset the notifications and counters, while unanswered incoming ACD calls would still be able to set them.

ACD Wallboard branding
The ACD wallboard application now offers branding capabilities, allowing you to customize several elements for a more personalized experience. The items available for branding include:
Favicon: This appears on the tab title.
Logo: Displayed on the login page.
Application Name: Shown on both the login page and the tab title.
URL: Visible in the URL navigation bar.

CRM Rules in Phone Manager - Display the calling number in national format
Give the ability to enterprise administrators to add a caller's number in national format to the CRM URL, enabling them to access relevant information in User Admi
E4SP Chat - Chat display performance improvement
Improved the IM chat to make it less reliable on persistent storage and speed up the chat display after a refresh.


Phone Manager Smart group history - Display performance improvement

Improved the display speed of the smart group in Phone Manager, especially when the call history exceeds 50 entries. Additionally, ensure that the missed calls history is displayed by default in Phone Manager to enhance user experience.


Third-party Integrations

Microsoft Azure AD (Entra ID) - Users import improvements
This feature significantly streamlines user creation by allowing the import of contacts from MS Azure AD directly into Apalo. Imports can be scheduled for immediate execution or set to occur daily, weekly, or monthly, ensuring that Apalo users remain current.
Additionally, users who are deleted in Azure AD can also be removed from Apalo, depending on the selected settings. At the
conclusion of each import, an Excel report provides a comprehensive overview of changes—including removals, updates, and new creations—along with any potential errors encountered during the process.

Microsoft Teams Meetings and Presence integration provisioning automation

This feature is designed to streamline configuration and improve the user experience for companies utilizing the Apalo platform alongside Microsoft Azure and Teams. It focuses on three primary objectives:
1. Direct Access to Teams Meetings: Users can view Teams meetings and launch them directly from Phone Manager.
2. Real-Time Presence Status Updates: Phone Manager users can now see their colleagues' presence statuses in nearly real-time within Apalo applications, eliminating the need to switch between different platforms.
3. Automated Initial Configuration: This feature allows enterprise administrators to efficiently and accurately establish the interconnection with their Microsoft Azure AD accounts through a simplified and guided setup process.


Analytics 3 - More up to date CDR analytics in CA3

To enhance the service, we implement cleaner handovers to third parties, facilitate universal data extraction from existing CDRs, and provide analytics updates at five-minute intervals.
These enhancements will be integrated into the Analytics 3 platform, which is powered by CA3.

OPS support

Cluster monitor Add profiling capability
Operations teams can now initiate the JVM profiler for a limited time to analyze the CPU performance of a specific module and download a flamegraph visualization.


Trace log improvement: Display the log trace "Websocket events" by default
This initiative aims to simplify the confirmation and monitoring of server-to-client events and notifications. By adjusting WebSocket events to INFO severity, it aligns them more closely with mobile app push notifications, enhancing clarity and responsiveness.


Quality Improvements

APIs

E4SP CRM API integration issues
User Admin API - Default audio returned instead of localized audio

Portals



User Admin
User Admin- "Access VM" IVR extensions not counted in enterprise "Other extensions"
User Admin- Admin without branding allowed can create admin with branding allowed
User Admin- Administrator sees other SP's service packs
User Admin- Branded URLs not available in consul after modification
User Admin- Cannot set a key with Action=BLF and Destination=CallPark
User Admin- Contact export download link raise 404
User Admin- Enterprise home page - The counts for softphone terminals are not correct
User Admin- One can see all other SP's calendars when editing welcome attendant
User Admin- Teams terminals must be associated to the special enterprise gw group only



Apalo Back End Admin
Apalo Back End Admin - Administrator history displays wrong updateInstance data
Apalo Back End Admin - Cannot anymore search by user agent from IP devices - column user agent missing
Apalo Back End Admin - FMC ProOn/Off - Misleading wording in User's config
Apalo Back End Admin - Forwarding rule - Bad translation day of the week for other language than English
Apalo Back End Admin - Microsoft Contacts import advanced filters not enabled by default



Phone Manager

Phone Manager - FMC ProOn/Off - Pro On / Pro OFF setup issue
Phone Manager - Not able to login (in some rare conditions)
Phone Manager - Voicemail label is incorrect
Phone Manager - “Timeouted” interruption in CallLine answerPrompt
Phone Manager desktop - Call control view fails to keep up-to-date - Inactive Tab Management in Chromium browser
Phone Manager desktop - M1 ARM CPU architecture not detected on the download page


Migrator CLI

Migrator - IP devices lines (speedial) not imported
Migrator - CamelTrunks / PbxTrunks removed

Collaboration


UC

Call handling - VCC not working on group calls
External forwarding not working when call comes already forwarded into EUP
RCR rules - Exception file on International RCR not applied
Silent calls to ACD groups with systematic recording
Systematic Recording - Recording missing for conference call
Posted Feb 11, 2025 - 11:12 UTC

Investigating

Details on Planned Works

Minor bug, User Interface and User Experience Improvements (PhoneManager, Useradmin, Reporting and Teams)

During the maintenance window we will be applying updates to improve the Back end Admin, User Interfaces and User Experience of UserAdmin and PhoneManager, expected impact to service will be minimal but maximum risk is a 30 min down time

If you have any questions regarding this notification please email support@apalo.co.uk

Regards

Team Apalo
Posted Jan 20, 2025 - 14:34 UTC
This incident affected: Voice (Inbound Voice, Outbound Voice), Interfaces (Phone Manager, User Admin, API), and Mobile (ApaloSIM).