Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 14, 2024 - 22:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted May 13, 2024 - 08:50 UTC
Scheduled
We are undertaking an emergency maintenance fix to our core services at 22:00 on the 14th May 2024. Services will be affected during the 15 minute restart process
Posted May 14, 2024 - 22:00 UTC
This scheduled maintenance affected: Voice (Inbound Voice, Outbound Voice), Interfaces (Phone Manager, User Admin, API), and Mobile (Voice, SMS / Mobile Data, ApaloSIM).