EE Outage

Incident Report for Apalo

Resolved

EE have announced that they have completed the fix over the weekend.
Posted Jul 28, 2025 - 08:11 UTC

Investigating

There is still issues with the EE network throughout the UK, Following an incident on BT network End users may unable to establish or receiving calls.
Posted Jul 25, 2025 - 12:44 UTC
This incident affected: Mobile (Voice, SMS / Mobile Data, ApaloSIM).