Windows update impacting Phone Manager 3.1.7

Incident Report for Apalo

Resolved

All versions of phone manager have now been compiled and updated to 3.3.3, all existing 3.1.7 instances will be triggered to upgrade.
Posted Jan 13, 2025 - 21:32 UTC

Update

If you would like to test 3.3.3 prior to release, it is available branded as uccloud, please contact us and we will send a link to download the binaries. Once we have completed our tests we intend to push the binaries to update the individual apps. It is also update Mac apps as well. send an email to support@apalo.co.uk.
Posted Jan 09, 2025 - 13:05 UTC

Monitoring

Version 3.3.3 has been compiled and we are testing the uccloud.io instance, we are still on track to complete all brands by close of play today
Posted Jan 09, 2025 - 09:54 UTC

Investigating

We have had several reports of phone manager 3.1.7 not behaving correctly post windows update, this has not affected all windows machines, but we have had several reports of Lenovo machines.

We are currently compiling and testing a phone manager release to address the issues and hope to have this fully deployed by close of business tomorrow.
Posted Jan 08, 2025 - 16:17 UTC
This incident affected: Interfaces (Phone Manager).